
~Page 1~ 

Spss Lab 7: T-tests 
Section 1 

 
In this lab, we will be using everything we have learned in our text and applying 
that information to understand t-tests for parametric and nonparametric data.  
 
THERE WILL BE TWO SECTIONS FOR THIS LAB, EACH CONTAINING TASKS TO 
COMPLETE. SEE ME WHEN YOU FINISHE ONE SECTION TO RECEIVE THE NEXT 
SECTION.  
 
Task 1: Your Data 
Go to our course webpage (http://laura.goadrich.com/stats/lab.html). Under the 
lab section you will find SpiderRM.sav and SpiderBG.sav 
 
The data is arranged as if the same participants were used in each condition (so 
each participant was exposed to a picture of a spider and their anxiety was 
measured, and at some other time the same participants were exposed to the 
real spider and their anxiety was measured again). 
 
Each row in the data editor represents a different participant’s data.  

1. Download SpiderRM.sav (RM is for repeated measures) and 
SpiderBG.sav (BG is for between group) to your computer to use for the 
assignment. 

2. Create a Word file Lab7.doc to put your solutions to the tasks below. Put 
your name at the top of the file.  

 
Task 2: Dependent t-test 
Constructing a dependent t-test is very straightforward in SPSS. Using 
SpiderRM.sav, access the main dialogue box by  

1. Going to Analyze -> Compare Means -> Paired-Samples T Test…  
2. Select the two variables from the list (at the same time, so they are both 

highlighted in blue) and move them to the box labeled Paired Variables 
using the arrow. 
 

At this point, if you want to carry out several t-tests then you would select another 
pair of variables, transfer them to the variables list, and then select another pair 
and so on.  

3. Click on the Options… button 
4. In the new dialogue box, change the confidence interval to 99% 
5. Click OK 
6. Copy your three charts from the Output window to your Word document.  

 
Answer the following questions in your Word document:  

a. What is the risk of changing the confidence interval from 95% to 99%? 
b. Looking at the first table created, is the Paired Sample Statistics table 

showing you the results from independent-means or repeated-measures? 
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c. Using the results from the same table, Paired Sample Statistics, describe 
the differences in the data created by the “picture of the spider” and the 
“real spider.” 

d. Looking at the last table created, is the Paired Sample Test table showing 
you the results from independent-means or repeated-means? 

e. Using the results from the same table, Paired Sample Test, describe the 
differences in the data created by the “picture of spider” and the “real 
spider.” 

f. Using what you have learned, on average, which participants experienced 
significantly greater anxiety? Justify your answer by discussing the t-score 
and the chosen alpha value. 

 
Task 3: Independent t-test 
Constructing a independent t-test is very straightforward in SPSS. Using 
SpiderBG.sav, access the main dialogue box by  

1. Go to Analyze -> Compare Means -> Independent Samples T Test… 
2. Once the dialog box is activated, select the dependent variable from the 

list (anxiety) and transfer it to the box labeled Test Variable(s) by using 
the arrow.  

3. Next select the independent variable (group) and then transfer it to the 
box labeled Grouping Variable. 

4. Click the button for Define Groups… 
5. Enter 0 for the Group 1 (the picture group) 
6. Enter 1 for the Group 2 (the real group) 
7. Click Continue 
8. Click OK 
9. Copy your new tables to your Word document.  

 
Answer the following question in your Word document: 

g. What differences do you notice in your Group Statistics table and your 
Paired Sample Statistics (the first table you copied for the lab) table?  

 
The second table contains the main test statistics. One row is labeled Equal 
variances assumed while the other is labeled Equal variances not assumed. This 
has to do with the equal variance assumption; we only have to pay attention to 
the first row. 
 
We want to compare the results in Sig.(2-tailed) column with the data in the t 
column (the t-value).  
 
Answer the following question in your Word Document: 

h. What can you infer about the anxiety caused by the pictures and by real 
spiders?  
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Spss Lab 7: T-tests 
Section 2 

 
Sometimes our data does not fit the normal curve (non-parametric data). In class 
you were given a handout about two tests that are alternatives to our 
independent t-test and handle nonparametric data.  
 
Task 4: Your Data 
For this section, you will need to create your data set with its associated values.  
The study results that you are entering are from a neurologist that carried out an 
experiment to investigate the depressant effects of certain recreational drugs. 
She tested 20 clubbers in all: 10 were given an Ecstasy tablet to take on 
Saturday night and 10 were allowed only to drink alcohol. Levels of depression 
were measured using the Beck Depression Inventory (BDI) the day after and 
midweek.  
 
To create your SPSS data, 
 

1. Open SPSS and create a new Data file.  
2. Save the file as lab7.sav  
3. Add your variables: 

 

 
4. And your associated values: 

Drug sunbdi wedbdi
Ecstasy 15 28 
Ecstasy 35 35 
Ecstasy 16 35 
Ecstasy 18 24 
Ecstasy 19 39 
Ecstasy 17 32 
Ecstasy 27 27 
Ecstasy 16 29 
Ecstasy 13 36 
Ecstasy 20 35 
Alcohol 16 5 
Alcohol 15 6 
Alcohol 20 30 
Alcohol 15 8 
Alcohol 16 9 
Alcohol 13 7 
Alcohol 14 6 
Alcohol 19 17 
Alcohol 18 3 
Alcohol 18 10 

 

Name Label 
Drug Type of Drug 

sunbdi Beck Depression Inventory (Sun) 
wedbdi Beck Depression Inventory (Wed) 
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Task 5: Understanding simplified data  
(To understand this section, you must read the packet I gave you covering the 
Wilcoxon and Mann-Whitney tests.) 
 
Both of the tests you are about to do work very similarly. First imagine that there 
is no difference in depression levels between Ecstasy and Alcohol users. 
Suppose we were to rank the data ignoring the group to which a person 
belonged from lowest to highest (i.e. give the lowest score a rank of 1 and the 
next lowest a rank of 2 etc.). 
 
Answer the following question in your word document: 

i. If you summed the ranks of both groups separately (given the above 
conditions), what number of high and low ranks would you expect in each 
group? 

j. What about the summed total of ranks in each group? 
 
Now let’s think about what would happen if there was a difference between the 
groups. Let’s imagine that people in the Ecstasy group are more depressed than 
the people in the Alcohol group.  
 
Answer the following question in your word document: 

k. If you summed the ranks of both groups separately (given the above 
conditions), what number of high and low ranks would you expect in each 
group? 

l. What about the summed total of ranks in each group? 
 
The Mann-Whitney and Wilcoxon rank-sum tests both work on this principle. In 
fact, when the groups have unequal numbers of participants in them then the test 
statistic for Wilcoxon’s rank-sum test is simply the sum of the ranks in the group 
that contains the fewer people; when the group sizes are equal it’s the value of 
the smaller summed rank.  
 
 
Task 6: Understanding our data 
Let’s apply this ranking idea to our data set and watch what happens. First we 
will need to add some more variables to lab7.sav 

1. After sunbdi, add sunRank and sunActualRank.  
2. Similarly after wedbdi, add wedRank and wedActualRank.  
3. Sort the Wednesday scores in ascending order 
4. Now assign ranks in wedRank from 1 (for the smallest value) to 20 (for 

the largest value) 
 
Now we want to assign the actual ranks for the wedbdi values. This will not 
always match up with the wedRank values because when the scores occur more 
than once in the data set (e.g. in these data a score of 6 occurs twice and a 
score of 35 occurs three times). These tied ranks need to be given all the same 
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rank. So assign a rank that is the average of the potential ranks for those scores. 
For example, with the 6s, you would take (3 + 4)/2=3.5; so under 
wedActualRank for the wedbdi values of 6 and 6, you would type 3.5 and 3.5 

5. Assign the appropriate values for wedActualRank 
 
After you’ve ranked the data, add up all the ranks for the two groups. 
 
Answer the following questions in your Word document: 

m. What is the sum of ranks for the Alcohol group? 
n. What is the sum of ranks for the Ecstasy group? 

 
We take the lowest of these sums to be our test statistic.  
 
Answer the following questions in your Word document: 

o. So, what is the test statistic for Wednesday? 
 
Repeat the process above (steps 1-5) to calculate sunRank and 
sunActualRank. 
 
In SPSS Data View, select all your data and copy it (Edit -> Copy). Go to your 
Word Document and paste the data into it (Edit -> paste). With the data still 
highlighted, create a table around it (Table -> Insert -> Table) 
 
Answer the following questions in your Word document (about the Sunday 
group): 

p. What is the sum of ranks for the Alcohol group? 
q. What is the sum of ranks for the Ecstasy group? 
r. So, what is the test statistic for Sunday? 

 
 
Task 7: Significance using the Wilcoxon rank-sum test 
Now we need to determine whether this test statistic is significant. Given  

1n  is the sample size of group 1 (Alcohol) and  

2n  is the sample size of group 2 (Ecstasy) 

Calculate the mean = ( )
2

1211 ++ nnn  

And standard error = ( )
12

12121 ++ nnnn  

 
Answer the following questions in your Word document: 

s. What is the mean and standard error? 
t. Now use a z-score to convert the test statistic to a z-score for both Sunday 

and Wednesday. 
u. What is your critical value when p<0.05 for a two-tailed test? 
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v. Is there a significant difference between the groups on Wednesday and/or 
Sunday? 

 
 
Task 8: Significance using the Mann-Whitney test 
This test is basically the same to with Wilcoxon rank-sum test, but your 
significance formulas will be reduced to one.  
 
Given 

1n  is the sample size of group 1 (Alcohol) and  

2n  is the sample size of group 2 (Ecstasy) 

1R = the sum of ranks for Ecstasy data for the given day 

2R = the sum of ranks for Alcohol data for the given day 
 

Test statistic for the Alcohol data: ( )
1

11
21 2

1
R

nn
nn −

+
+  

Test statistic for the Ecstasy data: ( )
2

11
21 2

1
R

nn
nn −

+
+  

 
Answer the following questions in your Word document: 

w. What is the value for the test statistic for the Sunday Ecstasy data? 
x. What is the value for the test statistic for the Sunday Alcohol data? 
y. Using the Mann-Whitney U table (Appendix B.9A in your text), what is 

your critical value when p<0.05 for a two-tailed test? 
z. Is there a significant difference between the Ecstasy and Alcohol groups 

on Sunday? 
aa. Repeat the above analysis (w through z) for Wednesday. 

 
 
Task 9: Mann-Whitney U-test & Wilcoxon signed-ranks test 
Now let’s have SPSS do the work for us.  

1. Open your lab7.sav  
2. Click on Analyze -> Nonparametric Tests -> 2 Independent Samples… 
3. Add sunbdi and wedbdi to the box labeled Test Variable List by 

highlighting the variable and clicking the arrow. 
4. Select drug as the independent variable by highlighting it and clicking the 

appropriate arrow to move it to the box labeled Grouping Variable. 
5. Click on the Define Groups… button 

 
SPSS needs to know what numeric codes you assigned to your two groups. We 
coded the Ecstasy group as 1 (so put a 1 in group 1) and the Alcohol group as 2 
(so put a 2 in group 2).  

6. Click Continue 
7. Under Test Type, you should have a check mark next to Mann-Whitney U 
8. Click OK 
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Copy your two charts from your output window to your Word document.  
 
Answer the following questions in your Word document: 

bb. Looking at the charts you copied, do your results from task 7 & 8 match (if 
not they should)?  

cc. How can you determine if there was a significant difference based on the 
charts alone? 

 
 
Task 10: Wrap-up 
Print out Lab7.doc and sign the honor code.  
 
Turn in your electronic version of Lab7.doc via blackboard and the paper copy to 
Laura by the end of the lab session.  


